import Foundation
let pattern = #"\b(?<!\S)(?:(Lord|Lady|Ser)\s+)?(Agatha|John)?(?:\s*(?<=\b)(Cain))?(?<=\S)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Lord John Cain asked...
Ser John has...
Lady Agatha and Lord John are...
Lady Agatha Cain was...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating...
He looked at them. Cain was walking...
Cain is...
Outside the castle, in a small courtyard, a page was leading Ser
John and his horse into the stables.
Yes, my lord... My Lord Tom, that is...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)