const regex = /\b(?<!\S)(?:(Lord|Lady|Ser)\s+)?(Agatha|John)?(?:\s*(?<=\b)(Cain))?(?<=\S)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!\\S)(?:(Lord|Lady|Ser)\\s+)?(Agatha|John)?(?:\\s*(?<=\\b)(Cain))?(?<=\\S)\\b', 'gi')
const str = `Lord John Cain asked...
Ser John has...
Lady Agatha and Lord John are...
Lady Agatha Cain was...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating...
He looked at them. Cain was walking...
Cain is...
Outside the castle, in a small courtyard, a page was leading Ser
John and his horse into the stables.
Yes, my lord... My Lord Tom, that is...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}