import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+?1?[-.\\s]?)(\\d{3})([-.\\s])(\\d{3})\\2(\\d{4})$";
final String string = "+1-555-235-2444\n"
+ "1-555-235-2444\n"
+ "1.555.235.2444\n"
+ "1 555 235 2444\n"
+ "555-235-2444\n"
+ "(555) 234-2341\n"
+ "5552342341\n"
+ "555 2341234\n"
+ "555-2341234";
final String subst = "(\\1) \\3 \\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}