use strict;
my $str = '+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234';
my $regex = qr/^(?:\+?1?[-.\s]?)(\d{3})([-.\s])(\d{3})\2(\d{4})$/mxp;
my $subst = '(\\1) \\3 \\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";