import Foundation
let pattern = #"^(?:\+?1?[-.\s]?)(\d{3})([-.\s])(\d{3})\2(\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1) \3 \4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)