#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+:\d{2}:\d{2}$"
Local $sString = "01:00:00" & @CRLF & _
"1:00:00" & @CRLF & _
"30:21:21" & @CRLF & _
"330:21:21" & @CRLF & _
"1330:21:21" & @CRLF & _
"11330:21:21" & @CRLF & _
"0:0:0" & @CRLF & _
"0:" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"30:211:211" & @CRLF & _
"30:2111:2111" & @CRLF & _
"a:d:d" & @CRLF & _
"asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")