$re = '/^\d+:\d{2}:\d{2}$/m';
$str = '01:00:00
1:00:00
30:21:21
330:21:21
1330:21:21
11330:21:21
0:0:0
0:
0
1
30:211:211
30:2111:2111
a:d:d
asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);