using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+:\d{2}:\d{2}$";
string input = @"01:00:00
1:00:00
30:21:21
330:21:21
1330:21:21
11330:21:21
0:0:0
0:
0
1
30:211:211
30:2111:2111
a:d:d
asd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}