import re
regex = re.compile(r"^\d+:\d{2}:\d{2}$", flags=re.MULTILINE)
test_str = ("01:00:00\n"
"1:00:00\n"
"30:21:21\n"
"330:21:21\n"
"1330:21:21\n"
"11330:21:21\n"
"0:0:0\n"
"0:\n"
"0\n"
"1\n"
"30:211:211\n"
"30:2111:2111\n"
"a:d:d\n"
"asd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")