# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^<[^\n<>]+>\h+<[^<>\n]+>\h+"|\G(?!^))[^_\n]+\K_(?=[^"\n]*")/ /gm;t' <<< "<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/author> \"Graeme_Base\" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base\" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base_test1_test2\" ."