# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^<[^\n<>]+>\h+<[^<>\n]+>\h+\"|\G(?!^))[^_\n]+\K_(?=[^\"\n]*\")"
test_str = ("<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/author> \"Graeme_Base\" .\n"
"<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base\" .\n"
"<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base_test1_test2\" .")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.