const regex = /(?:^<[^\n<>]+>\h+<[^<>\n]+>\h+"|\G(?!^))[^_\n]+\K_(?=[^"\n]*")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^<[^\\n<>]+>\\h+<[^<>\\n]+>\\h+"|\\G(?!^))[^_\\n]+\\K_(?=[^"\\n]*")', 'gm')
const str = `<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/author> "Graeme_Base" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> "Graeme_Base" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> "Graeme_Base_test1_test2" .`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);