import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^<[^\\n<>]+>\\h+<[^<>\\n]+>\\h+\"|\\G(?!^))[^_\\n]+\\K_(?=[^\"\\n]*\")";
final String string = "<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/author> \"Graeme_Base\" .\n"
+ "<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base\" .\n"
+ "<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> \"Graeme_Base_test1_test2\" .";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}