using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^<[^\n<>]+>\h+<[^<>\n]+>\h+""|\G(?!^))[^_\n]+\K_(?=[^""\n]*"")";
string substitution = @" ";
string input = @"<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/author> ""Graeme_Base"" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> ""Graeme_Base"" .
<http://dbpedia.org/resource/Animalia_(book)> <http://dbpedia.org/property/illustrator> ""Graeme_Base_test1_test2"" .";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}