using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R+";
string substitution = @"\n";
string input = @"This is text line 1
This is text line 2
This is text line 3";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}