$re = '/\R+/u';
$str = 'This is text line 1
This is text line 2
This is text line 3';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;