package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\R+`)
var str = `This is text line 1
This is text line 2
This is text line 3`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}