use strict;
my $str = 'This is text line 1
This is text line 2
This is text line 3';
my $regex = qr/\R+/up;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";