#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[ \n]([A-Z]{1}[a-z]{3,25})[ \n]*([A-Z]{1}[a-z]{0,25})?[ \n]*([A-Z]{1}[a-z]{2,25})?$"
Local $sString = "a" & @CRLF & _
"" & @CRLF & _
"aReare git" & @CRLF & _
"" & @CRLF & _
"Ishtiyaq Husain" & @CRLF & _
"" & @CRLF & _
"aeet fa DOB: 01/04/1986" & @CRLF & _
"" & @CRLF & _
"eS" & @CRLF & _
"" & @CRLF & _
"get / MALE." & @CRLF & _
"" & @CRLF & _
"——" & @CRLF & _
"" & @CRLF & _
"Pa" & @CRLF & _
"" & @CRLF & _
"S" & @CRLF & _
"" & @CRLF & _
"8739 5445 7455"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")