import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\n]([A-Z]{1}[a-z]{3,25})[ \\n]*([A-Z]{1}[a-z]{0,25})?[ \\n]*([A-Z]{1}[a-z]{2,25})?$";
final String string = "a\n\n"
+ "aReare git\n\n"
+ "Ishtiyaq Husain\n\n"
+ "aeet fa DOB: 01/04/1986\n\n"
+ "eS\n\n"
+ "get / MALE.\n\n"
+ "——\n\n"
+ "Pa\n\n"
+ "S\n\n"
+ "8739 5445 7455";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}