package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ \n]([A-Z]{1}[a-z]{3,25})[ \n]*([A-Z]{1}[a-z]{0,25})?[ \n]*([A-Z]{1}[a-z]{2,25})?$`)
var str = `a
aReare git
Ishtiyaq Husain
aeet fa DOB: 01/04/1986
eS
get / MALE.
——
Pa
S
8739 5445 7455`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}