re = /[ \n]([A-Z]{1}[a-z]{3,25})[ \n]*([A-Z]{1}[a-z]{0,25})?[ \n]*([A-Z]{1}[a-z]{2,25})?$/
str = 'a
aReare git
Ishtiyaq Husain
aeet fa DOB: 01/04/1986
eS
get / MALE.
——
Pa
S
8739 5445 7455'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end