# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[ \n]([A-Z]{1}[a-z]{3,25})[ \n]*([A-Z]{1}[a-z]{0,25})?[ \n]*([A-Z]{1}[a-z]{2,25})?$"
test_str = ("a\n\n"
"aReare git\n\n"
"Ishtiyaq Husain\n\n"
"aeet fa DOB: 01/04/1986\n\n"
"eS\n\n"
"get / MALE.\n\n"
"——\n\n"
"Pa\n\n"
"S\n\n"
"8739 5445 7455")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.