use strict;
my $str = 'a
aReare git
Ishtiyaq Husain
aeet fa DOB: 01/04/1986
eS
get / MALE.
——
Pa
S
8739 5445 7455';
my $regex = qr/[ \n]([A-Z]{1}[a-z]{3,25})[ \n]*([A-Z]{1}[a-z]{0,25})?[ \n]*([A-Z]{1}[a-z]{2,25})?$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}