using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z"" ]+ *, *[1-9][0-9]?(\n|$))+$";
string input = @"Sam ""The Man"" McAdams , 9
Sam ""The Man"" McAdams , 9
Sam ""The Man"" McAdams , 9";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}