$re = '/^([a-zA-Z" ]+ *, *[1-9][0-9]?(\n|$))+$/';
$str = 'Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);