const regex = /^([a-zA-Z" ]+ *, *[1-9][0-9]?(\n|$))+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z" ]+ *, *[1-9][0-9]?(\\n|$))+$', '')
const str = `Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}