import re
regex = re.compile(r"^([a-zA-Z\" ]+ *, *[1-9][0-9]?(\n|$))+$")
test_str = ("Sam \"The Man\" McAdams , 9\n"
"Sam \"The Man\" McAdams , 9\n"
"Sam \"The Man\" McAdams , 9")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")