re = /^([a-zA-Z" ]+ *, *[1-9][0-9]?(\n|$))+$/
str = 'Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9
Sam "The Man" McAdams , 9'
# Print the match result
str.match(re) do |match|
puts match.to_s
end