# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<code>).*?\K<\/code>|<(\/?[^\>]+)>/ /siug;t' <<< "вне тега<p>внутри</p><code><b>жирный</b></code><a href='#'>Ссылка</a>
"