use strict;
my $str = 'вне тега<p>внутри</p><code><b>жирный</b></code><a href=\'#\'>Ссылка</a>
';
my $regex = qr~(?<=<code>).*?\K</code>|<(/?[^\>]+)>~siup;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";