using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<code>).*?\K</code>|<(/?[^\>]+)>";
string substitution = @" ";
string input = @"вне тега<p>внутри</p><code><b>жирный</b></code><a href='#'>Ссылка</a>
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}