#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?siu)(?<=<code>).*?\K</code>|<(/?[^\>]+)>"
Local $sString = "вне тега<p>внутри</p><code><b>жирный</b></code><a href='#'>Ссылка</a>" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)