const regex = new RegExp('(?<=<code>).*?\\K</code>|<(/?[^\\>]+)>', 'siug')
const str = `вне тега<p>внутри</p><code><b>жирный</b></code><a href='#'>Ссылка</a>
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);