# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\\?|\,|%])/$1?$2/g;t' <<< "https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
"