use strict;
my $str = 'https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
';
my $regex = qr/([^\\?|\,|%])/p;
my $subst = '$1?$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";