package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\\?|\,|%])`)
var str = `https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
`
var substitution = "$1?$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}