$re = '/([^\\\\?|\,|%])/';
$str = 'https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
';
$subst = "$1?$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;