const regex = /([^\\?|\,|%])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\\?|\\,|%])', 'g')
const str = `https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
`;
const subst = `$1?$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);