using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\\?|\,|%])";
string substitution = @"$1?$2";
string input = @"https://images.hicarbyecar.com/uploads/2016/10/Audi_R8_V10_%E2%80%93_Frontansicht,_13._Ma?rz_2011,_Wuppertal1.jpg
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}