#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<!\\)\"(.*?)\"(?<!\\\"))"
Local $sString = "String x = "hello My name is \" John \" ";" & @CRLF & _
"char c2 = '\"';" & @CRLF & _
"String s = "adsf"; " & @CRLF & _
"String s2 = "asdf" + "asdf";" & @CRLF & _
"" & @CRLF & _
"String s = "Hello my name is \"John\" ";" & @CRLF & _
"String x = "asdf" char c = '\"';" & @CRLF & _
"String x = "asdf" + "asdf"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")