import Foundation
let pattern = #"((?<!\\)\"(.*?)\"(?<!\\\"))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
String x = "hello My name is \" John \" ";
char c2 = '\"';
String s = "adsf";
String s2 = "asdf" + "asdf";
String s = "Hello my name is \"John\" ";
String x = "asdf" char c = '\"';
String x = "asdf" + "asdf"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)