re = /((?<!\\)\"(.*?)\"(?<!\\\"))/
str = 'String x = "hello My name is \\" John \\" ";
char c2 = \'\\"\';
String s = "adsf";
String s2 = "asdf" + "asdf";
String s = "Hello my name is \\"John\\" ";
String x = "asdf" char c = \'\\"\';
String x = "asdf" + "asdf"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end