$re = '/((?<!\\\\)\"(.*?)\"(?<!\\\\\"))/';
$str = 'String x = "hello My name is \\" John \\" ";
char c2 = \'\\"\';
String s = "adsf";
String s2 = "asdf" + "asdf";
String s = "Hello my name is \\"John\\" ";
String x = "asdf" char c = \'\\"\';
String x = "asdf" + "asdf"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);