using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\\)\""(.*?)\""(?<!\\\""))";
string input = @"String x = ""hello My name is \"" John \"" "";
char c2 = '\""';
String s = ""adsf"";
String s2 = ""asdf"" + ""asdf"";
String s = ""Hello my name is \""John\"" "";
String x = ""asdf"" char c = '\""';
String x = ""asdf"" + ""asdf""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}