import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!\\\\)\\\"(.*?)\\\"(?<!\\\\\\\"))";
final String string = "String x = \"hello My name is \\\" John \\\" \";\n"
+ "char c2 = '\\\"';\n"
+ "String s = \"adsf\"; \n"
+ "String s2 = \"asdf\" + \"asdf\";\n\n"
+ "String s = \"Hello my name is \\\"John\\\" \";\n"
+ "String x = \"asdf\" char c = '\\\"';\n"
+ "String x = \"asdf\" + \"asdf\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}