import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\d+)x\\d+(?:,\\d+)?)?\\d+(k?g|g|m?l)";
final String string = "0,5g\n"
+ "500l\n"
+ "1000kg\n"
+ "20,5ml\n"
+ "20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}