$re = '/(?:(\d+)x\d+(?:,\d+)?)?\d+(k?g|g|m?l)/m';
$str = '0,5g
500l
1000kg
20,5ml
20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);