// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(\d+)x\d+(?:,\d+)?)?\d+(k?g|g|m?l)").unwrap();
let string = "0,5g
500l
1000kg
20,5ml
20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}