const regex = /(?:(\d+)x\d+(?:,\d+)?)?\d+(k?g|g|m?l)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\d+)x\\d+(?:,\\d+)?)?\\d+(k?g|g|m?l)', 'gm')
const str = `0,5g
500l
1000kg
20,5ml
20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}